accucell-6 balancing works poorly

Motors, speed controllers, batteries and other e-power stuff

accucell-6 balancing works poorly

Postby Rixx » Fri Nov 18, 2011 3:20 pm

Hi guys. I wonder if there is solution to this, or should I get new charger... My charger was working OK for about 2 years, but lately it takes too long to finish balancing. Yesterday it was balancing 2s460 nanotech. Charger dsiplayed charged capacity of about 1500mAh, but afte 4 hours of balancing it still was not finished. It read all cells at 4.20 V, but still was pushing in 0.3A at 8.38V. (I tried with old batteries, new ones, regular and nanotechs, same result)

I disconnected battery and measured cells at 4.17 and 4.18 V. I took another battery, calibrated charger, and I charged cells individually as 1s. They got charged perfectly to 4.2V. Then I connected this battery to balancer as usually, and it read 4.25 and 4.22V, and started discharging cells to about 4.17V. Seems like calibrating affects only power output, but not balancing ports. So it looks like charger tries to top the voltage of the whole pack via power leads, while bleeding off current via balancer to about 4.17 volts per cell, in endless loop...

My last try before getting new charger, is to calibrate charger to read a little higher voltage than actual, to match balancer offset. This way my accus would get charged to only 4.17 V, but it would actually finish the charging :D

Any ideas? :?:
Posts: 42
Joined: Fri Dec 10, 2010 7:41 am

Return to Electric Power Systems

Who is online

Users browsing this forum: No registered users and 2 guests