Page 1 of 1

Turnigy ESC 85a/4Sbec

PostPosted: Sun Sep 16, 2012 5:12 am
by Iwade
Any one any ideas? This is a dead(pun) common question I guess.
My beautiful,until now, ESC has died. Last Saturday was flying a HobbyKing Yak 54 , the balsa one. Set up was Turnigy 3548/900KV, 3s 2200 20C lipo and 11x7 prop. Had to land dead stick to find motor very hot and emitting dreadful smells. The Rx side and servos were still working fine. However once home I swapped a motor to test system and ESC failed to play it's opening tune and refuses to operate the motor.
Just wondering is there any way I can test the ESC to maybe isolate the fault. Or any ideas on what may have happened to it. I am no electronic whiz kid so any testing would have to be pretty basic. The ESC did not smell hot or burnt in any way and when I removed the alloy case it still looks good as new under there. No signs of burn or heat.
Any hints or remedies gratefully accepted. Thanks - Peter ( old but not grumpy! )

Re: Turnigy ESC 85a/4Sbec

PostPosted: Sun Sep 16, 2012 9:48 am
by BillGriffiths100
It sounds as though the microprocessor has failed the burning smell from the motor is an indicator that the fets were turning on incorrectly toasting the motor windings.
The BEC is an independent circuit not involved in the speed control hence its continued functioning.
The fact that it's doing nothing beepwise means no processor activity I'm afraid.
There's very little / nothing you can do about this economically it's probably a bin job.

Re: Turnigy ESC 85a/4Sbec

PostPosted: Mon Sep 17, 2012 1:00 am
by Iwade
Thanks Bill, worried it may be something like that. "Ah well what the hell" as McWatt said when he flew into the side of the mountain.
I'm getting quite good at binning things...

Re: Turnigy ESC 85a/4Sbec

PostPosted: Mon Sep 17, 2012 7:48 am
by BillGriffiths100
Look on the bright side you haven't chopped anyone in half!