Accucel-8 charger problems

If you've got a problem then you can ask here and either I or others will likely come to your rescue.

Accucel-8 charger problems

Postby Daedalus » Thu Jul 01, 2010 10:43 am

Hi,
I have two Accucel chargers, a 6 and an 8.
The 6 works well, without any hassles at all, but the more expensive 8 won't go when it cold.
I keep my gear in my garage and up until a couple of days ago it was unheated.
Prior to heating the garage, if I went to use the accucel 8 it would just show a partial line on the screen (like a shaded area).
If I then took it inside my home and left it for half an hour, then try it and it would work fine.

I have posted this on HK's forum and have had little responce, other than being told the IC's don't like the cold and that is probably whats wrong.
One person did mention poor solder joints contracting. Is that possible?
Does anyone else have this sort of problem? if so could they fix it?

I did try to disassemble it for inspection, but its not so simple and I'm concerned I may make matters worse.

Any ideas?

Wayne
Daedalus
 
Posts: 23
Joined: Tue May 04, 2010 8:16 am

Re: Accucel-8 charger problems

Postby RCModelReviews » Thu Jul 01, 2010 9:49 pm

It's not uncommon to have faults that are temperature related.

It can be a bad solder joint -- such that when its cold, the two parts which should be soldered (but aren't) contract and thus move away from each other and the connection is broken. Once things are warmed up, the bits expand and are pushed back into contact.

Unfortunately this can also happen deep inside some components such as ICs. If there's an insecure bonding between the pins and the fine wires that connect those pins to the slice of silicon inside, you can get the very same effect and the only cure is to replace the part.

You may be able to buy a can of electronic freeze spray that can be used to track down the exact part of the circuit which is heat/cold sensitive. Close inspection of this area may reveal a bad connection that you can resolder.

However, you have to weigh up the cost of the spray and your time against the fact that you might not be able to fix it anyway. Remember we live in a disposable society :-(
RCModelReviews.com, just the facts.
User avatar
RCModelReviews
 
Posts: 2120
Joined: Tue May 04, 2010 3:40 am

Re: Accucel-8 charger problems

Postby Daedalus » Fri Jul 02, 2010 4:26 am

thanks for your reply Bruce,
I think I'll leave well alone at this stage, while its still working anyway.

Just a bit frustrated that I have an accucel 6 thats works great, then lash out and buy the "better" model and its dodgy.

I guess its a lesson on buying overseas as well - you buy and take your chances.
I have had it for a while now and apart from this problem it works faultlessly and I would still recommend it to others.


cheers
Wayne
Daedalus
 
Posts: 23
Joined: Tue May 04, 2010 8:16 am


Return to Help Needed

Who is online

Users browsing this forum: No registered users and 1 guest

cron