TREX 600 ESP - Softstart

For helis powered by volts rather than fuel

TREX 600 ESP - Softstart

Postby takilara » Fri Jul 30, 2010 7:03 am

Hello.
I just finished my build two days ago, and yesterday I did my maiden flight.

The heli flew perfectly, and I love it!!!

One issue i had though, it seemed that the softstart on the ESC is not working 100%

Whenever I want to spool up, the motor starts turning very slowly, but does not increase in RPM, it also seems that it "stutters" as it turns, after a few seconds, it gives up and dies. Then i need to throttle back down, then up again, and it will try again.

After 4-6 attempts like this, it manages to increase RPM, and after this i have no problem with power.

After 5 mins of hover, the ESC, batt and connectors are cool, the motor is warm (not hot)
The ESC is setup to defaults, (brakes disabled, medium timing, hight voltage cutoff, soft start (no governor), and quick throttle response)

(i had a linear throttlecurve in the Tx when programming the ESC, and the ESC gives the correct beeps, so the programming should be as i anticipate)
When flying i use a throttlecurve of 0,40,65,87,100

The mesh between the motor and the main gear might be a little tight, but if i spin the gear a full turn, i have some play at some points of the gear, and no play in others.

Anyone have any ideas regarding this?
The price of getting what you want;
is getting what you once wanted...
_____
T-REX 600 ESP
CopterX 450AE V2
Multiplex FunCub
Belt-CP
User avatar
takilara
 
Posts: 144
Joined: Mon May 17, 2010 7:53 am
Location: Stavanger - Norway

Re: TREX 600 ESP - Softstart

Postby vfrjohn » Tue Aug 10, 2010 6:28 pm

Have you tried changing the ESC "timing" parameter?

I gather that can affect the startup characteristics, as well as efficiency, etc.
vfrjohn
 
Posts: 9
Joined: Mon Aug 09, 2010 4:38 am

Re: TREX 600 ESP - Softstart

Postby vfrjohn » Tue Aug 10, 2010 6:32 pm

Oh, a side comment -

I don't think the ESC cares what the throttle curve looks like for programming purposes. It just needs the zero and max points to select/set parameters. You can set the stick full up and use the throttle hold switch to do the programming, if you like.
vfrjohn
 
Posts: 9
Joined: Mon Aug 09, 2010 4:38 am

Re: TREX 600 ESP - Softstart

Postby takilara » Tue Aug 10, 2010 6:47 pm

No I haven't tried to change the timing, I'll give it a shot when my Rx is working again.

I have flown the heli about 10 times now, and its always acting up on softstart, but sometimes it manages to get it starting on the first attempt. It really acts just like a very old car that you have to turn over the ignition several times before it gets going..

The ESC do care about the throttlecurve when programming, Min and max is fine, issue is the middle point.
With my stick at middle, the ESC would register high instead of middle.
The price of getting what you want;
is getting what you once wanted...
_____
T-REX 600 ESP
CopterX 450AE V2
Multiplex FunCub
Belt-CP
User avatar
takilara
 
Posts: 144
Joined: Mon May 17, 2010 7:53 am
Location: Stavanger - Norway

Re: TREX 600 ESP - Softstart

Postby vfrjohn » Tue Aug 10, 2010 7:38 pm

Thanks for expanding on the programming. Obviously, I spoke from a position of limited knowledge!
What brand/model ESC are you using? Does it use Min, Midpoint and Max for programming functions?
The only one I've used so far (Tower Pro 40) only cares about the throttle output going to zero and max. For example, if I have the throttle curve set so the max point is only 80%, the ESC won't program.
vfrjohn
 
Posts: 9
Joined: Mon Aug 09, 2010 4:38 am

Re: TREX 600 ESP - Softstart

Postby takilara » Tue Aug 10, 2010 7:46 pm

on the TREX 600 it is a stock Align ESC, 100A i think, that has 3 positions for most of the settings.
On my Cx450 i have a hobbywing pentium 40, that only uses max and min.

It is generally a good thing to set throttlecurve to linear 0-25-50-75-100 before programming, then set it back afterwards.
(on my Cx i have about 85 at mid stick, so that would not have been accepted for midstick either.
The price of getting what you want;
is getting what you once wanted...
_____
T-REX 600 ESP
CopterX 450AE V2
Multiplex FunCub
Belt-CP
User avatar
takilara
 
Posts: 144
Joined: Mon May 17, 2010 7:53 am
Location: Stavanger - Norway

Re: TREX 600 ESP - Softstart

Postby siang » Wed Aug 11, 2010 9:26 am

One of my mates trex 500 does the same, everytime. If I remember correctly it's soft, normal and hard. DON'T use hard start, it can damage your one way bearing sleeve.
User avatar
siang
 
Posts: 50
Joined: Tue May 04, 2010 1:28 pm
Location: Auck, NZ

Re: TREX 600 ESP - Softstart

Postby takilara » Wed Aug 11, 2010 10:11 am

I think for this ESC it is soft, soft including governor, and hard (aircraft mode).

I have left it in soft for now. People say that the governor is useless, and hard will be very hard on the gears and one way bearing
The price of getting what you want;
is getting what you once wanted...
_____
T-REX 600 ESP
CopterX 450AE V2
Multiplex FunCub
Belt-CP
User avatar
takilara
 
Posts: 144
Joined: Mon May 17, 2010 7:53 am
Location: Stavanger - Norway

Re: TREX 600 ESP - Softstart

Postby MojoMaestro » Mon Apr 23, 2012 11:37 pm

i have the same Heli with same ESC, it seems to be a common issue,
so i have read before the build.

i just leave mine on Normal.
VERUS AMICUS EST TANQUAM ALTER IDEM

Heli : Xieda 9958/Falcon 400 3D (Edge body)/EXI 450 ZL pro/EXI 500 CF/T-Rex 600 ESP (Airwolf body).
Plane : AXN Floater Jet (mod)/Cessna 182 (mod)/Mini-Saturn 3D/Mini-Cuckoo (4 times)/DIY Sky Riders Spartan EDF
.
User avatar
MojoMaestro
 
Posts: 35
Joined: Wed Mar 28, 2012 11:35 am
Location: Montreal, Quebec, CANADA

Re: TREX 600 ESP - Softstart

Postby takilara » Mon Apr 30, 2012 1:44 pm

Hello

A few flights after i posted that question, it stopped doing that stuttering. It now works fine. I had almost forgotten about the issue :P
The price of getting what you want;
is getting what you once wanted...
_____
T-REX 600 ESP
CopterX 450AE V2
Multiplex FunCub
Belt-CP
User avatar
takilara
 
Posts: 144
Joined: Mon May 17, 2010 7:53 am
Location: Stavanger - Norway


Return to Electric Power

Who is online

Users browsing this forum: No registered users and 3 guests