HELP! TH9x Rudder issue w/video

Problems, experiences or just something to say about RC gear? Say it here.

HELP! TH9x Rudder issue w/video

Postby Willage » Mon Apr 09, 2012 6:12 pm

Hi Bruce. Long time fan and viewer of your channel. I am having a problem with my transmitter and was hoping you or one of your followers can help.

Here is the issue written out. I will post a link to a video so you can see the issue in action.

I have a TH9x transmitter. I have modified it with a Smartie Parts board (smartieparts.com) which made it easy to update the firmware to the ER9x firmware and gave me the backlit feature as well.
The system has been operating beautifully until recently. What is happening is that when flying with a plane with rudder, as I throttle up and give any right rudder the rudder begins to act erratically. I get some left rudder coming into play. Sometimes a little flick of left rudder or sometimes full deflection left rudder. This is happening when holding full right rudder. This link will show the issue on video.

http://youtu.be/GL_3vFQqHLc

Hope you can help.

Thanks in advance.
William
Willage
 
Posts: 3
Joined: Sun Sep 04, 2011 12:41 am

Re: HELP! TH9x Rudder issue w/video

Postby RCModelReviews » Mon Apr 09, 2012 8:02 pm

Make sure that the wiring to the control pots is good. During the fitting of the board you may have stressed that wiring a little and it could be that when you move the throttle (which causes the rudder pot to move with it) the flexing of the wires involved is creating an intermittent connection. Check also that the connectors are firmly reseated in the main circuit board and that none of the pins have accidentally been bent during the re-insertion process.

I'd be expecting that you'd find a broken wire or bad solder joint on one of the three wires that go to the rudder pot on the rudder stick unit -- or maybe a wire that's broken just inside the insulation -- although I have also heard of some pots going bad where the connecting tab is riveted or pressed onto the pot itself.
RCModelReviews.com, just the facts.
User avatar
RCModelReviews
 
Posts: 2120
Joined: Tue May 04, 2010 3:40 am

Re: HELP! TH9x Rudder issue w/video

Postby Willage » Tue Apr 10, 2012 4:25 am

Thanks Bruce. I did go into the back of my TX and found the black wire had come lose from behind the gimbal. I was hesitating going in since I am no electronics whiz and wouldn't know what to look for, but luckily it was obvious. A little desoldering braid, my soldering iron, cleaned it up and re-soldered the wire. Working perfectly.
thanks for the reply.

Keep up the good work on the show. When I got a few extra buck I will contribute to the show, I get a lot of knowledge and entertainment (thanks Ron:))

Willage
Willage
 
Posts: 3
Joined: Sun Sep 04, 2011 12:41 am


Return to Radios and Servos

Who is online

Users browsing this forum: No registered users and 1 guest