Spektrum AR6200 glitch and crackup...

Problems, experiences or just something to say about RC gear? Say it here.

Spektrum AR6200 glitch and crackup...

Postby Capt Crash » Sat Jun 26, 2010 4:21 am

Bummer. For the past year, my new DX7 and its associated receivers have worked well. However, that record just went up in a cloud of dust and plant debris as my CMPro Giles Alien suffered a loss of communication after an aborted takeoff roll. I throttled down to taxi back and used the rolling energy of the plane to turn 180 degrees, but then I heard the engine rev up without any input of mine, sending the plane into an embankment covered with shrubs. Thankfully, no one was hurt, the Alien is mostly intact and will be easily repaired, and only my pride and ego suffered a bruising. Still, why the problem? The system was powered by a new, freshly charged 2000 mAh NiMH battery. The plane was not that far away, and had passed range testing. The antennas were set up so that they were not blocked by any metal parts of the airplane. For some reason, the receiver lost comms with the transmitter, and tragically the failsafe for the throttle was incorrectly set my yours truly (hey, I earn my nickname the old fashioned way: by doing some stupid things here and there). Still, I'm not finding any reasons for the loss of comms.

I've seen a fair slew of posts linking the AR6200 receiver to problems; can anyone out there corroborate this? I'm also flying a plane on an AR7000 and have never had any problems with this setup. I have another plane with an AR6200, but will ground it until I get some answers. I know: buyer beware, you get what you pay for, there's a sucker born every minute, etc. etc. I'm not asking Horizon to repair my plane; I'm a certifiable dumb a$$ for not rechecking throttle failsafe position after binding, and realize that they can't be held responsible for my lack of competence with their system. But the anecdotal evidence seems to be stacking up that there's something wrong with the AR6200 that causes it to lose comms in ways that the AR7000 doesn't.

The details:

Airframe: CMPro Giles 202 V2 Alien 140 size, with hefty aluminum main spar, but no carbon fiber that I know of
Engine: GMS 1.20
Servos: Tower TS-70 metal gear analog, with MPi gold plated extensions and MPi Miracle Y reverser for elevator servos
Battery: Hydrimax 6v 2000 mAh NiMH
Switch: Spektrum switch
Receiver: Spektrum AR6200 with satellite
Transmitter: Spektrum DX7

I know I got off easy because I got to take my plane home and despite a bit of rash on the wings, it's essentially intact and will fly again. But I can't stop thinking about it. Maybe the servos draw too much current when operated? Maybe the system locked onto two freqs too close to each other, and both were blanked by interference? Maybe the Miracle Y generates interference and is incompatible with the Spektrum system? Maybe I should stick to foamie electrics or try a safer hobby like stamp collecting? Any comments and suggestions are welcome.
Capt Crash
 
Posts: 1
Joined: Sat Jun 26, 2010 3:51 am

Return to Radios and Servos

Who is online

Users browsing this forum: No registered users and 3 guests