Page 1 of 1

Turnigy 9x / Frsky suddenly fails

PostPosted: Mon Dec 23, 2013 8:48 pm
by Ed_2000
Hello everybody,

I’m in trouble with a Turnigy 9x and I’d appreciate very much your opinion.

I installed the FrSky DHT DIY module following Bruce’s instructions. Everything worked well. But every once in a while (not always) when I’m flying my HK 450 heli it loses power as if it was turned off completely and falls down.

I tried replacing one by one: receiver, ESC, motor, gyro, battery and trying after each individual change and the error repeats each time.

Then, I bought a new Frsky module and replaced it in the transmitter. The error continues.

Then I tried the heli with friend’s non-modified Turnigy 9x and it’s turnigy receiver and the heli flies perfectly.

I saw the last post about the failing on/off switch, but it doesn’t seem to be the problem, because if I move it in different ways while it’s ON it doesn’t seem to turn off the radio.

So… finally, I think some internal part of the radio doesn’t work. I can’t imagine any other part to replace.

Any ideas?

Thanks for your input,

Re: Turnigy 9x / Frsky suddenly fails

PostPosted: Tue Dec 24, 2013 9:18 am
by BillGriffiths100
You need to identify what's failing more precisely, is it the transmitter failing, does the screen blank when the failure occurs?
Do you need to switch off the transmitter and then turn it on again to regain control?
Try with another receiver and see if it still controls that when it's not controlling the helicopter.
Are you using the stock firmware, it really needs to be upgraded to the new open source software which can reset the processor in case of a microprocessor glitch.
for lots of helpful information on problems like yours.

Re: Turnigy 9x / Frsky suddenly fails

PostPosted: Tue Dec 24, 2013 2:10 pm
by Ed_2000
Thank you for your answer Bill.

The screen doesn't blank and I don’t need to switch off-on the transmitter, it works well after one second or two but in helicopters that’s enough to cause a crash. After these couple of seconds I have control again on the heli and in any other receiver in my other models

I’m using the stock firmware that came with the transmitter, maybe the upgrade to the open source can solve the problem. I’ll take a look at the forum you send me.

Thanks again.