Turnigy 9x V2 LCD Screen Replacement

Problems, experiences or just something to say about RC gear? Say it here.

Re: Turnigy 9x V2 LCD Screen Replacement

Postby BillGriffiths100 » Fri Sep 30, 2011 12:13 pm

Keith wrote:I thought it was my ribbon cable at first... There is no way to hold the cable in while you push down the two end pieces... When I closed the case I thought something may have pushed to hard on it... But it can't be that as it worked for about five minutes, and now I get the splash screen for a split second before it goes black (not blank)....

Hi Keith,
If the screen shows the splash screen for a moment and it had worked for five minutes previously it is possible that you need to re flash the software, the Atmel processor eprom may have not been programmed sufficiently over the threshold it needed to retain the program.
Otherwise the processor may be a dud but the display either works or it doesn't the indication is that the processor runs to a certain point and then jumps out of program.
Compromising with out of control government is like living with a lion, sooner or later the bloody thing will eat you .

You accept the tyranny of the state when it's not being applied to you, when it is: it's too late.
User avatar
BillGriffiths100
 
Posts: 553
Joined: Mon Sep 20, 2010 2:04 pm
Location: London UK

Re: Turnigy 9x V2 LCD Screen Replacement

Postby Keith » Sat Oct 01, 2011 10:30 am

Thanks Bill, that was the problem... As soon as I re-flashed everything started working...
I may still have a problem though... After it was finished I got the msg:- Bad EEprom Data... I used the latest version this time, r546...
I'm guessing I got a dodgy eprom...?
If anyone is feeling a bit paranoid....BEHIND YOU....
Keith
 
Posts: 219
Joined: Fri Jul 01, 2011 2:22 pm
Location: Melbourne... Australia...

Re: Turnigy 9x V2 LCD Screen Replacement

Postby FlyingTiger » Sun Oct 02, 2011 4:32 am

FlyingTiger wrote:Well, I knew it would happen. I got my replacement screen and opened up the radio to install it. Everything was going fine and I even wired in a switch to control the back light. I liked the Hobby King back light more than the one that comes with the Smartieparts board since it's brighter. I put it all back together and there is nothing on the screen. Just blank. So I check the connection and the little plastic shim that holds the ribbon cable for the screen in the connector is bent. I try a little force to push it in further and don't you know, it just breaks in half. Any ideas on how to seat my ribbon cable now? Damn, I hate when I screw up something so royally that ought to be so simple.


Yay! I got it fixed. I just kept shoving things into the connector slot until I had enough thickness to push the ribbon against the pins and enough friction to keep it from falling out. I love low tech solutions.
Gear up and locked!
User avatar
FlyingTiger
 
Posts: 61
Joined: Thu Apr 28, 2011 2:13 pm
Location: Atlanta Georgia USA

Re: Turnigy 9x V2 LCD Screen Replacement

Postby BillGriffiths100 » Mon Oct 10, 2011 8:54 am

Keith wrote:Thanks Bill, that was the problem... As soon as I re-flashed everything started working...
I may still have a problem though... After it was finished I got the msg:- Bad EEprom Data... I used the latest version this time, r546...
I'm guessing I got a dodgy eprom...?

Hi Keith,
sorry about the delay in replying no you are OK you always get that message the first time you turn on as the eeprom doesn't have any data yet. The message will disappear when you turn off and on again.
You are good to go as you probably have found out by now!
Regards,
Bill
Compromising with out of control government is like living with a lion, sooner or later the bloody thing will eat you .

You accept the tyranny of the state when it's not being applied to you, when it is: it's too late.
User avatar
BillGriffiths100
 
Posts: 553
Joined: Mon Sep 20, 2010 2:04 pm
Location: London UK

Re: Turnigy 9x V2 LCD Screen Replacement

Postby Keith » Mon Oct 10, 2011 10:51 am

Yep, all good Bill... Thanks again...
If anyone is feeling a bit paranoid....BEHIND YOU....
Keith
 
Posts: 219
Joined: Fri Jul 01, 2011 2:22 pm
Location: Melbourne... Australia...

Previous

Return to Radios and Servos

Who is online

Users browsing this forum: No registered users and 3 guests

cron