Page 2 of 2

Re: FrSky D8R Rxs In Stock

PostPosted: Tue May 08, 2012 8:19 pm
by Szilard
Hi pldb64, and thx for your quick response :)

I do have ... duct=22693 because I forgot about that built-in sensor :D
Can I connect this "directly" to the Rx? I have the full kit but I want to use this on a heli where I only care about the voltage ;)
The sensor unit has a tiny two pin connector with yellow and black wires, while the Rx has a three pins: Ground, +5V, and Rx. If I used JR type servo plug I would connect the black wire to the Rx's "ground" pin, the yellow to the Rx's "Rx" pin but where should I get 5 volts? :)

Re: FrSky D8R Rxs In Stock

PostPosted: Wed May 09, 2012 1:21 am
by pldb64
Hi Szilard,

The sensor you've shown is the LiPO voltage sensor and it plugs into the sensor hub. So the answer is NO ... it won't plug directly into the Rx. You'd need the sensor hub which then plugs into the data port on the Rx (NOT A1/A2).

For measuring your flight battery pack, your options are:
1. Battery voltage sensor - (product ID - FBVS-01)

This requires you to solder one end of the sensor to the battery leads (either the +/- leads on the battery side of the ESC or the +/- leads from the balance leads). You can also choose whether you want to measure 5S packs (the default setting on the little board) or solder it so that it measures 3s (or 1s) packs. This is a very simple solder job and is explained in the doco. The reason to do this is that if you're flying 3S packs, you'll get greater resolution on the voltage being sensed by making the change.

Then you plug the other end of the sensor directly into the A2 port of the Rx.

Note that the built in sensor in the Rx measures your Rx voltage only - not your flight pack voltage - so it will be showing 5.0, 5.5 or 6.0 volts depending on how you've configured it. This (IMHO) has limited value if you're also measuring flight pack voltages. The Rx voltage will be shown as the A1 measured value.

2. LiPO battery sensor - (Product ID - FLVS-01)

This is the cell by cell sensor with teh OLED display. In order to send this data back to the Tx, you need to include the sensor hub ( This sensor is connected to teh flight packs balance leads and then connects to the hub. The hub is then connected to teh data port of your Rx.

Note that if you're using the FLD-02 display like i am, then only A1, A2 and RSSI alarms can be set on the DJT/DHT Tx modules. (ie you can't set an alarm to sound for the FLVS-01).

If you're using the DHT-U display/Tx combined unit, then i understand that this allows you to set more alarms (including those of the FLVS-01). Hopefully a SW upgrade will be available soon so that FLD-02 users can do this too ... but no word on that yet.

Personally, i have both the FBVS-01 and the FLVS-01+hub. I'm only using the FBVS-01 at the moment and setting my alarms using the FLD-02 for low voltage on my flight packs.

Hope that helps.

Re: FrSky D8R Rxs In Stock

PostPosted: Wed May 09, 2012 1:26 am
by pldb64
This thread might also be of interest to you:


Re: FrSky D8R Rxs In Stock

PostPosted: Wed May 09, 2012 12:21 pm
by Szilard
Thanks for your input Peter, I didn't know half of that :D
Apparenlty the thing I'm looking for is that FBVS-01 thing, I'll put the other one on my plane.
Thanks a lot for all that info.

Re: FrSky D8R Rxs In Stock

PostPosted: Sat May 19, 2012 6:35 pm
by Szilard

I assembled the telemetry system, I installed the Data screen on my DJT Tx module, I installed the GPS sensor, and the FLVS-01 voltage sensor on my V2 sensor hub, but the voltage screen doesn't come up at all could you guys tell me what could be wrong? Maybe I should upgrade some firmware?


P.S.: When I connected the hub's lead to the A1 port on the receiver suddenly everything worked :D
Now that I get telemetry I can tell that my model is 112meters high (yes ground level is this high where I live ;) )and I'm getting speed data too even without vario. I put my PDA with a gps antenna near it to verify the altitude reading and that read 130 meters. So there's a bit of discrepancy there (18 meters), but it works now :)