ER9x w FrSky DIY - no servo control - Help

If you've been building electronic bits or modifying stuff you've bought then tell us all about it here. A good place to discuss the installation of 2.4GHz DIY modules too.

ER9x w FrSky DIY - no servo control - Help

Postby RandomBob » Mon Jul 04, 2011 1:20 pm

Hi everyone, reasonably new to the world of RC, but have been flying 4ch helis for a little while now, moving onto 6ch and attempting planes.

Got myself a 9x with the the smartieparts board, and now have ER9x firmware on there.
Also installed the FrSKy DIY module in there.

My problem is that after binding a frsky rx with the tx, i can't seem to control the servo (almost like no signal) at all.
i have successfully bound 3 frsky receivers, so binding isn't an issue.
each time i turn the tx on and off they connect up really quickly again, so the rx seems to be receiving a signal.

I plug in a servo into any of the first 4 channels and no stick movement makes the servo move. Currently i have set it up with ch3 as throttle so this is where i plug in a esc (HK-10A esc) and into the esc i plug in the battery (2s 7.2v).
On the tx i have used the simple 4ch template and i can see that assigns the first 4 channels.

I have tried the V8R7-SP, V8R4 and the V*FR-HV recieves and can not get any servo movement.
I have tried the analogue HXT900 servo and the HKSCM9 digital servo and it seems the digital servo makes a constant beeping. (even after checking it plugged in properly.)

Im hoping someone can give me some guidance as to what i should check. I
It seems to me that its more of a ER9x firmware thing that i may not have enabled or the correct setting, as the server initializes when the rx is powered up, and there is a connection between the rx and tx.

I have watched the intro to the ER9x
T9x + Er9x - Step by Step - Lesson 01
and read the manual, and the Simple 4 Channel Tutorial by ghost.

Hopefully its something rather stupid that i have just missed out.
The home screen of the TX shows EXP and V next to the battery voltage.

Any input would be great.
(PS, in perth if there any locals that think they can give me a hand...)
Posts: 1
Joined: Mon Jul 04, 2011 12:33 pm

Re: ER9x w FrSky DIY - no servo control - Help

Postby rogueqd » Sat Jul 16, 2011 5:48 pm

I have the standard hobbyking V2 firmware, but two simple things in case you've overlooked them. Is the radio set to PCM, and have you checked the soldering for the yellow wire?
Posts: 234
Joined: Thu Mar 10, 2011 1:52 am
Location: Northern beaches, Sydney, Australia

Return to DIY Projects and Hacks

Who is online

Users browsing this forum: No registered users and 4 guests