Spektrum DSMX

Discussion on the reviews of 2.4GHz radios, modules and receivers that have appeared on RCModelReviews..com

Re: Spektrum DSMX

Postby cynr100 » Sun Oct 07, 2012 12:50 am

RyanNX211 wrote:I'm not sure things have improved with the AR600.

We had two more lockouts. http://www.thebuildingboard.com/2012/10 ... -line.html


Hey RyanNX211 not sure why you included this link, went nowhere regarding AR600 that I could find.
Not enough time in the day for all my crazy ideas, I'm not slow, I'm just pacing myself
User avatar
cynr100
 
Posts: 821
Joined: Wed Jan 25, 2012 7:37 am
Location: Cairns, Australia

Re: Spektrum DSMX

Postby RyanNX211 » Sun Oct 07, 2012 3:59 am

Sent the wrong link.
Anyhow, there have been a lot more complaints since Spektrum replaced all of our AR500s with new AR600s
RyanNX211
 
Posts: 14
Joined: Sat Feb 05, 2011 11:31 pm

Re: Spektrum DSMX

Postby cynr100 » Sun Oct 07, 2012 11:33 am

RyanNX211 wrote:Sent the wrong link.
Anyhow, there have been a lot more complaints since Spektrum replaced all of our AR500s with new AR600s


I guess then now would be the right time to send the correct link, just to keep those interested informed.
Not enough time in the day for all my crazy ideas, I'm not slow, I'm just pacing myself
User avatar
cynr100
 
Posts: 821
Joined: Wed Jan 25, 2012 7:37 am
Location: Cairns, Australia

Re: Spektrum DSMX

Postby RyanNX211 » Sun Oct 07, 2012 11:58 am

It gets truncated when I put it in the reply. Maybe because Bruce was banned there
RyanNX211
 
Posts: 14
Joined: Sat Feb 05, 2011 11:31 pm

Re: Spektrum DSMX

Postby doublebuck » Thu Mar 28, 2013 10:02 am

Hi All,

I hope I am in the right area for this but I have consistent problems with getting my Spectrum Non DSMX DX 5 to bind. When I power up any receiver (Orange clone or Spectrum AR400 etc.) the receiver will not bind and I have to reconnect the receiver. I have tried rebinding but still have problems. I have sent the DX5 to be rechecked with the manufacturer but still it does not bind correctly. This problem arises when initial binding has been successful. I am at my wits end and desperately need help from you experts! Please help-I am thinking of trashing all my Spectrum stuff.

Ron
doublebuck
 
Posts: 1
Joined: Thu Mar 28, 2013 9:47 am

Previous

Return to 2.4GHz radios/modules/receivers

Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests

cron