My first tri-copter crash :)

To discuss all things relating to flying models via remote video

My first tri-copter crash :)

Postby Mark Hitchman » Wed Apr 11, 2012 10:35 pm

I replaced the EZOSD, camera and wiring on my tricoptor to save weight and so I could install a 5amp/hr battery instead of the 3amp/hr one I was running. I replaced the 10 X 5 props with 11 x 5.5 ones and also installed a Dragonlink receiver in the process. The crash was due to low voltage from not using a fully charged battery and presuming my current/voltage sensor needed calibrating, turns out they were accurate :)
No harm done because I came in low as the throttle was starting to get mushy.

http://www.youtube.com/watch?v=pJzdAoF5MbM
Mark Hitchman
 
Posts: 22
Joined: Mon Jul 25, 2011 10:29 am

Re: My first tri-copter crash :)

Postby Mark Hitchman » Thu Apr 12, 2012 2:27 am

Forgot to mention since putting on the 11 X 5.5 props I need to lower the gains on the flight controller, it was oscillating a fair bit and went wild a couple of times.

Mark
Mark Hitchman
 
Posts: 22
Joined: Mon Jul 25, 2011 10:29 am

Re: My first tri-copter crash :)

Postby naja452 » Thu May 03, 2012 5:22 pm

So how long flight times do you get with a 5ah? I use a 2.2ah right now because threats the battery that was recommended, with a 5ah and bigger props do you actually get longer flights? I get about 15 to 19min.
naja452
 
Posts: 1
Joined: Thu May 03, 2012 5:19 pm


Return to FPV

Who is online

Users browsing this forum: No registered users and 0 guests

cron