Burned things up

Problems, experiences or just something to say about RC gear? Say it here.

Burned things up

Postby chixter57 » Sat Jan 19, 2013 6:22 pm

Hello to all, first time post on this informative board. I'm just getting back into the hobby after a 2 decade hiatus. Not wanting to bother with nitro engines and fuel and such, I was amazed at the progression of electronic airplane flight. So my adventure begins. I'm putting together an AXN per Bruces build videos. In the vids he advises to test the servos prior to installing them. And here is where I think I messed up. I COULD have used my already built Dynam Mustang, fired it up and plug the new servos in one at a time into say the 'elevator' terminal of the rx to ensure that they work. But in my clouded judgement I did the following instead:

I removed the Rx from the mustang and put it on my bench. I plugged the small plug from a new HK 25/30 3BEC ESC into the 'Throttle' terminal of the Rx. I connected 1 new HK 9g servo into the 'elevator' terminal of the Rx. All wiring/polarity etc was double checked....keep in ming the ESC was NOT wired to anything...just sitting on the bench. I plugged my Zippy 2200 20c Lipo into the ESC plug and......Instant SMOKE.

I def fried the ESC and as the Rx now does not function in the Mustang I believe I damaged it as well. Both the Rx and the ESC have that nice 'toasted electronics' smell to them.

1. What did I do wrong?
2. I have since ordered a servo testing gizmo. Did my setup not having the ESC wired to a motor cause my problem?

chixter
chixter57
 
Posts: 3
Joined: Sat Jan 19, 2013 6:04 pm

Re: Burned things up

Postby quarry44 » Sat Jan 19, 2013 8:22 pm

It sounds like a wiring problem.I believe the rx got the full voltage blast from the lipo,which would kill it stone dead.Motor not connected to esc makes no difference.Maybe the bec in the esc was disabled by default.Or there was a short in your wiring.
quarry44
 
Posts: 383
Joined: Fri Aug 19, 2011 6:58 am

Re: Burned things up

Postby chixter57 » Sun Jan 20, 2013 3:39 am

Close inspection of the ESC revealed very sloppy soldering of the chips on the bottom of the board. Many leads fused together with splashed solder. Everywhere my test leads touch on the board I read 000 Ohms. Could be the whole thing was shorted out before I ever plugged it in! I have a good photo but dont know how to post it here. I think I just got a POS ESC. Was a HK 25/30 3 BEC
chixter57
 
Posts: 3
Joined: Sat Jan 19, 2013 6:04 pm

Re: Burned things up

Postby chixter57 » Tue Jan 22, 2013 12:16 am

Ok to close this out. My 1st and LAST experience with HK electronics. All over on various boards I read that "they are inexpensive" as the only good character. This ESC was only $12 US but I'd rather pay 18-20 or even a bit more for one that will work as expected with reasonable qc than go the inexpensive route and just throw it in the trash because it's crap.
chixter57
 
Posts: 3
Joined: Sat Jan 19, 2013 6:04 pm

Re: Burned things up

Postby cynr100 » Tue Jan 22, 2013 11:30 am

I am now using Turnigy Plush ESC's (not all from HK by the way) from 18 to 40amp and have not had a proplem with any of them. Considering the amount of damage I do to my planes they have done very well.
I went the cheap way with 2 SS black units from HK, both were 25amp and did not survive more than 1 flight in my AXN using a 5x5.
I have a Skyartec 25amp that took a vertical entry to mother earth, after cleaning the mud off found the heat shrink had fractured and the heat sink had run away. Cleaned and dried the unit, added a new heat sink and shrink. It pulls 20amps on my AXN running a 6x4 without any issues.
Not enough time in the day for all my crazy ideas, I'm not slow, I'm just pacing myself
User avatar
cynr100
 
Posts: 821
Joined: Wed Jan 25, 2012 7:37 am
Location: Cairns, Australia

Re: Burned things up

Postby Keith » Tue Jan 22, 2013 12:11 pm

I use the "plush" ones when I can. Mostly 25A, never had a problem either on planes or multicopters...
If anyone is feeling a bit paranoid....BEHIND YOU....
Keith
 
Posts: 219
Joined: Fri Jul 01, 2011 2:22 pm
Location: Melbourne... Australia...


Return to Radios and Servos

Who is online

Users browsing this forum: No registered users and 1 guest

cron