LiFe battery and standard servo

Problems, experiences or just something to say about RC gear? Say it here.

LiFe battery and standard servo

Postby Chskin » Sat Sep 14, 2013 11:34 pm

Hello

I watched Bruce's video on RX batteries and very much enjoyed it. Just one follow up question:

I would like to know if a 2 cell LiFe battery is acceptable to use with a non-hi-voltage servo? The LiFe would be producing about 6.5v and the servos are rated for 4.8-6v. The servo I would be using is a Hitec 625MG. Basically I want to avoid using a BEC as it is one more thing to fail. So will a 6.0v servo work with a 2 cell LiFe or do I buy hi-voltage servos?

Thanks in advance

Craig
Chskin
 
Posts: 8
Joined: Thu May 10, 2012 12:43 pm
Location: Canada

Re: LiFe battery and standard servo

Postby RobC » Sun Sep 29, 2013 9:02 am

Apparently Hitec servos made a while ago are fine, however I bought some 645MGs a few weeks ago and these show a lot of drift on 2S LiFe, but are fine on 6v regulated. IE the neutral position varied from day to day. When I asked around a few people told me they'd found the same with Hitec servos made recently.
I run nearly everything else on 2S LiFe including Futaba 300x 900x and 3152s, JR, Hitec 225 485 325 and 311s, MG996Rs and various others. It's only my new 485MGs that need regulating.
RobC
 
Posts: 74
Joined: Tue May 04, 2010 11:38 am

Re: LiFe battery and standard servo

Postby pulsext » Wed Oct 02, 2013 9:42 pm

I have had two hitec 311 servos kick the bucket within a few months of use. It is also the first time I have used life batteries. I am a little nervous of using them unregulated now. It may of course be a manufacturing fault that caused both failures, yet it is very difficult to prove either way.
pulsext
 
Posts: 5
Joined: Sun Apr 21, 2013 1:00 pm


Return to Radios and Servos

Who is online

Users browsing this forum: No registered users and 3 guests