Optic 6 Sport pots offset?

Helicopter-specific issues relating to the electronics in your bird

Optic 6 Sport pots offset?

Postby mongo » Mon Dec 13, 2010 5:09 pm

Hi there,
first of I'd like to say I enjoy reading through this site a lot. Great job!

Now to the issue.
I've been given an old Optic 6 Sport with a weird issue. I cant seem to get the pots calibrated.
When I got into the service menu and try to adjust low/high/center positions they are all offset.
Instead of getting -400/0/400 I'm getting -330/-230/-180 on all the pots (and the high point wont even go beyond 0, probably a software limit).
What could be the problem here?
I'm guessing there's something going on with the analog/digital conversion. Voltage levels on the ADC maybe?
My electronic skills are limited to say the least, but I know my way around a multimeter and soldering.

Any help and/or information would be greatly appreciated.
Thank you, pardon my poor English and best regards from Slovenia.
User avatar
mongo
 
Posts: 4
Joined: Sun Sep 12, 2010 9:19 pm

Re: Optic 6 Sport pots offset?

Postby RCModelReviews » Mon Dec 13, 2010 11:25 pm

Should the range actually go from -400 to +400?

Do the sticks work normally otherwise (ie: do they command a full range of servo movement?
RCModelReviews.com, just the facts.
User avatar
RCModelReviews
 
Posts: 2120
Joined: Tue May 04, 2010 3:40 am

Re: Optic 6 Sport pots offset?

Postby mongo » Tue Dec 14, 2010 6:29 am

As far as I can tell from the service menu the range should go from -400 to 400 (with 0 at mid stick).
The interesting thing to me is that all sticks are doing the same thing, at first I thought it could be just a bad pot.
With the calibration at -330/-230/0 (0 should be -180, but can set it to that value due to how calibration is programed) the sticks have full travel to one side and maybe 10% in the other direction.
I'll make a video when I get home from work, it'll be easier to explain that way.
Thanks for the help.
User avatar
mongo
 
Posts: 4
Joined: Sun Sep 12, 2010 9:19 pm

Re: Optic 6 Sport pots offset?

Postby RCModelReviews » Wed Dec 15, 2010 6:45 am

I don't have a schematic for the Optic 6 but I suspect that the regulated supply which is fed to the sticks has failed and is too low in voltage.
RCModelReviews.com, just the facts.
User avatar
RCModelReviews
 
Posts: 2120
Joined: Tue May 04, 2010 3:40 am

Re: Optic 6 Sport pots offset?

Postby mongo » Thu Dec 16, 2010 10:49 am

Sounds plausible. Any way for me to measure the voltage to the pots?
I'm guessing there's no easy way to fix this?

I still haven't found the time to video the whole thing, maybe tonight if time permits.
User avatar
mongo
 
Posts: 4
Joined: Sun Sep 12, 2010 9:19 pm


Return to Radios, Gyros, Servos

Who is online

Users browsing this forum: No registered users and 0 guests